it-swarm.asia

ما المتطلبات اللازمة لإحدى webhoster لاستضافة Diaspora *؟

ما الذي أحتاجه للحصول على من webhoster إذا كنت ترغب في استضافة بلدي الشتات * البذور؟ هل أحتاج فقط إلى بعض مساحة الويب مع إمكانيات Ruby على Rails؟

4
bitbonk

متطلبات التثبيت من صفحة جيثب :

من أجل تشغيل الشتات ، ستحتاج إلى تنزيل التبعيات التالية (اتبع تعليمات محددة):

  • أدوات البناء - الحزم اللازمة لتجميع المكونات التالية.
  • Ruby - The Ruby لغة البرمجة. (نحن نستخدم 1.8.7. يتم تثبيته مسبقًا على نظام التشغيل Mac OS X.)
  • MongoDB - قاعدة بيانات noSQL سريعة.
  • OpenSSL - مكتبة تشفير. (يأتي مثبتًا مسبقًا على نظام التشغيل Mac OS X و Ubuntu.)
  • ImageMagick - مكتبة معالجة الصور تستخدم لتغيير حجم الصور التي تم تحميلها.
  • بوابة - نظام التحكم في الإصدار السريع.

بعد تثبيت Ruby على نظامك ، ستحتاج إلى الحصول على RubyGems ، ثم تثبيت Bundler:

  • RubyGems - المصدر لـ Ruby الجواهر.
  • Bundler - أداة إدارة الأحجار الكريمة للمشاريع Ruby.

هذا واقعي وراء ما يقدمه مضيف الويب النموذجي الخاص بك. (يعد Git وحتى Ruby غير قياسي لكثير من مضيفي ويب. MongoDB؟ احصل على outta هنا ...)

قد تكون أفضل حالًا باستخدام VPS.

5
Tom Wright

أنا آسف لأنني لا أستطيع الإجابة على سؤالك مباشرة ، ولكن هناك شيء واحد تحتاج إلى مراعاته هو ثغرات الأمان في هذا الإصدار ما قبل ألفا من Diaspora *:

http://www.theregister.co.uk/2010/09/16/diaspora_pre_alpha_landmines/

1
Erion