it-swarm.asia

كيفية خفض php من 7.1.1 إلى 5.6 في xampp 7.1.1؟

أريد تقليل إصدار php من 7.1.1 إلى 5.6 في xampp 7.1.1. ولكن لا يمكنني العثور على أي خيار.  PHP info from xampp 

11
Shiblee Sadik

أعتقد أن المسار الأكثر أمانًا للرجوع من PHP7 إلى PHP5 في Xampp هو:

  1. قم بتنزيل نسخة من Xampp ذات حزم ذاتية مع PHP5 من هنا (اعتبارًا من اليوم ، xampp-win32-5.6.37-0-VC11.Zip).

  2. إعادة تسمية المجلد php إلى php7 في Xampp.

  3. الآن قم بنسخ المجلد php من xampp-win32-5.6.37-0-VC11.Zip إلى مجلد تثبيت Xampp.

  4. عمل نسخة احتياطية من ملف \xampp\Apache\conf\extra\httpd-xampp.conf.

  5. استبدل هذا الملف من xampp-win32-5.6.37-0-VC11.Zip أيضًا.

  6. بهذه الطريقة ، تحتوي ملفات التكوين (بما في ذلك php.ini) على إعدادات من فريق Xampp.

أعلمني إذا فاتني شيء.

5
Lanti

لا يوجد خيار لخفض XAMPP. XAMPP هو hardcoded مع إصدار PHP محدد للتأكد من أن جميع الوحدات متوافقة وتعمل بشكل صحيح. ومع ذلك ، إذا كان مشروعك يحتاج إلى PHP 5.6 ، يمكنك فقط تثبيت إصدار قديم من XAMPP مع PHP 5.6 معبئة فيه.

المصدر:كيفية تخفيض php من 5.5 إلى 5.3

3
roundAbout

مجرد حذف هذا xampp ، وتنزيل 5.6 نسخة .

2
Arturs Jerjomins

XAMPP عبارة عن حزمة متكاملة ولا يمكنك الرجوع إلى أحد مكوناتها أو تغييرها مثل php. (هناك بعض الحلول التي يمكنك استخدامها ولكن هناك فرص ضئيلة في أن كل شيء يعمل بشكل جيد.)

يمكنك تنزيل الحزمة من هذه الروابط:

كان من الأفضل تنزيل نموذج الحزمة القديم sourceforge.net.

2
A mohseni

تغيير رمز .htaccess للتبديل إلى PHP 5.6:

AddHandler application/x-httpd-php56 .php
1
Adi

إذا كنت ترغب في تقليل إصدار php ، فما عليك سوى تحرير ملف .ttaccess لك. كما تريد تخفيض أي إصدار php إلى 5.6 ، فقط أضف هذا إلى ملف htaccess

<FilesMatch "\.(php4|php5|php7|php3|php2|php|phtml)$">  
etHandler application/x-lsphp56
</FilesMatch>
0
Md Zahid Shams

ليس لديك لتثبيت إصدار آخر من Xampp. لقد تمكنت من استخدام PHP 5.6 على Xampp PHP الإصدار 7. إليك ما تحتاج إلى القيام به لجعله يعمل:

  1. رانام (نسخة احتياطية) <XAMPP_DIR>\php إلى <XAMPP_DIR>\php~7
  2. نسخ (نسخة احتياطية) <XAMPP_DIR>\Apache\conf\extra\httpd-xampp.conf إلى <XAMPP_DIR>\Apache\conf\extra\httpd-xampp~7.conf
  3. تنزيل PHP5 وقم بفكها إلى <XAMPP_DIR>\php
  4. قم بتحرير <XAMPP_DIR>\Apache\conf\extra\httpd-xampp.conf وقم بتغيير كل تكرارات php5 إلى php7. تحتاج إلى تغيير php7Apache2_4.dll إلى php5Apache2_4.dll ، php7ts.dll إلى php5ts.dll و php7_module إلى php5_module
  5. تأكد من صحة جميع مساراتك مثل extension_dir في php.ini.

أعد تشغيل Apache و voila.

0
Erroid

إذا كنت ترغب في تقليل مستوى php من 7.1.1 إلى 5.6 في xampp ، فاتبع الخطوات (لنظام Windows): -

  1. انتقل إلى https://sourceforge.net/projects/xampp/files/XAMPP٪20Windows/5.6.36/
  2. قم بتنزيل واستخراج الملف xampp-win32-5.6.36-0-VC11.Zip راجع الصورة الصورة 1
  3. حذف php مجلد و أباتشي مجلد موجود في C:\xampp

  4. نسخ php مجلد و أباتشي مجلد من الملف المستخرج والصقه إلى C:\xampp

  5. أضف " C: " قبل\xampp \ في رقم السطر 709 ، 734 ، 816 ، 937 ، 1428 ، 1462 ، 2025 ، 2034 إلى php ini ملف موجود في php مجلد.

  6. ابدأ تشغيل Apache و MySQL وتحقق من نسخة php. سيظهر php 5.6.36

0
Mas