it-swarm.asia

مفقود SDK platform Android ، API 18

بينما أحاول تثبيت API 18 ، يظهر فقط "Google API 18" (لا أكثر). الآن إذا حاولت تثبيت واجهات برمجة تطبيقات google هذه من Android SDK Manager ، فسيظهر رسالة "this package depends on "Missing SDK platform Android, API 18". و زر التثبيت معطل.

هل لدى أي شخص هنا أي فكرة عن كيفية تثبيت API 18 (4.3_MR2 sdk) مع Eclipse

80
AAnkit

هل قمت بتثبيت إصدار أداة النظام الأساسي SDK 18؟ في SDK Manager ، سيكون هناك أحدث إصدار من أدوات SDK Platform التي يجب عليك تثبيتها أولاً ثم إعادة تشغيل Eclipse ثم محاولة تطبيق Android SDK API 18

enter image description here

101
Android Killer

افعل هذا أولاً:

كسوف> نافذة> Android SDK Manager> حزم> تحديث

ثم أعد محاولة التثبيت

19
Jainendra

طريقة أخرى لإصلاحها:

0) تثبيت حزم أخرى دون تحديد API 18 ،

1) إعادة تشغيل Eclipse ADT ،

2) افتح مدير SDK ، ثم يجب أن يظهر API 18 rev 1.

6
jozmedia

في وقت متأخر من اللعبة ، نفس المشكلة. لم تظهر أدوات SDK وليس أدوات Platform SDK. كانت هذه عملية من 4 خطوات:

  1. Eclipse/Help/Check for Updates ، تثبيت كل ما تم العثور عليه ، إعادة تشغيل Eclipse
  2. Eclipse/Window/Android SDK Manager - مستودع دعم تثبيت Android (شكرًا ، BurDog). مغلق مدير SDK.
  3. Eclipse/Window/Android SDK Manager - الآن أدوات SDK Android (Rev 22) ظهرت في الأعلى ، مثبتة. مغلق مدير SDK
  4. الآن ظهرت أدوات نظام Android SDK في قسم API 18 - المثبت. أعد تشغيل Eclipse (أو لن يتوفر API 18 في كل مكان).

وأخيرا جيدة للذهاب لبناء نسخة جديدة.

4
cdonner

هذه هي الطريقة التي أصلحت بها الألغام:

  1. ضمن "بيان ذاكرة التخزين المؤقت" ، انقر فوق "مسح ذاكرة التخزين المؤقت"
  2. انتقل إلى "الحزم" وانقر على "تحديث"
  3. تحقق أدوات -> أدوات منصة SDK الروبوت
  4. تثبيت فقط هذه الحزمة
  5. أعد تشغيل SDK Manager
2
jweaver

كان لديه نفس المشكلة. الرسالة كانت:

package google apis Android api 18 revision 1 يعتمد على مفقود sdk platform Android api 18

لقد حللت مثل الخطوات التالية:

  1. Eclipse -> مساعدة -> ابحث عن تحديثات (ثم انقر فوق "موافق" عند سؤالك - هل تريد تثبيته - انقر فوق "موافق"/"نعم" لإعادة تشغيل Eclipse لإنهاء التثبيت))
  2. نافذة -> Android SDK Manager -> قم بإلغاء تحديد الكل (ثم انتقل لأسفل إلى إضافات وحدد فقط مستودع دعم Android ، عند عدم تثبيته ، قم بتثبيته)
  3. نافذة -> Android SDK Manager -> تثبيت حزم xx

عملت بشكل جيد بالنسبة لي.

2
BurDog

كان لي نفس الموقف. بالنسبة لي عملت تحديث ADT البرنامج المساعد إلى الإصدار 22.0.5 ، وإغلاق Eclipse. ثم - الكسوف> نافذة> Android SDK Manager> الحزم> تحديث. نأمل أن هذا سوف يساعد شخص ما.

2
Mike

كسوف> نافذة> Android SDK Manager> حزم> تحديث

هذا عملت لي. شكر! الآن يمكنني التحديث إلى 18. أنا جديد هنا وحاولت التصويت على مشاركة جاغوار ، لكنني لا أستطيع.

1
user2636459

لقد حللت مع هذا:

  1. افتح Android SDK Manager -> حزم -> تحديث
  2. أعد تشغيل Android SDK Manager
  3. تثبيت الحزم "المفقودة" (أصبحت مرئية الآن)
1
Diego Sabolo

يبدو وكأنه نوع من klukey ، كان لدي مشاكل مماثلة. أخيرًا حصلت على واجهة برمجة تطبيقات msi 18 عندما قمت بتحديث أدوات sdk إلى 22 مما أدى إلى حدوث خطأ آخر وهو أن الأدوات كانت متدهورة عند إعادة التحميل. فتحت sdk mgr مرة أخرى وكان لدي 22.3 وأدوات النظام الأساسي ل rev19 وبعض الخيارات الأخرى أداة المتاحة. قمت بتحديث آخر لهم مع API19 و API 18 ويبدو أنه يتحرك الآن. أعتقد أنه ربما لواجهة برمجة تطبيقات 18+ يجب تحديث أدوات SDK إلى 22.3 في هذه المرحلة. راجع للشغل ، كما أنني حصلت على قفل ملف أثناء جزء من العملية وإغلاق Eclipse في الخلفية وضرب محاولة إعادة المحاولة. دانغ .. المقبل يقول أن ADT يجب أن يكون الإصدار 22.0+ ..
لقد قمت بتحديث ADT إلى 22.3 باستخدام برنامج Eclipse/help/install الجديد (جرب التحديث ببساطة أنه محدث) ... خطأ محتوى غير موقع واحد .. تمت إعادة تشغيل ADT بعد التحديث .. العمل من ما أستطيع أن أقول حتى الآن.

1
user2933604

لم أستطع تثبيت SDK جديد من Eclipse (مساعدة -> تثبيت برنامج جديد/التحقق من وجود تحديثات) ، اشتكى من تثبيت الإصدار الجديد بالفعل. ومع ذلك ، لم تظهر SDK الجديد في مدير SDK.

لقد قمت بحلها عن طريق تثبيت إصدار SDK الجديد من خلال سطر الأوامر: Android update sdk - no-ui

بعد ذلك ، كان من الممكن تحديث واجهات برمجة تطبيقات google والأدوات الأخرى عبر مدير SDK.

0
Jana
  1. يحتاج الحد الأدنى من حزم sdk و sdk.
  2. قمت فقط بتثبيت الحد الأقصى من sdk أي ، API18 3. يعتمد أيضًا على حزم sdk الأخرى بحد أدنى
0
priya

واجهت مشكلة مماثلة لك (بحتة من وصف المشكلة) ، لكن أدوات Android SDK Platform-WAS الخاصة بي مثبتة بالفعل (16.0.2). جميع الحزم الأخرى لم تتعرف عليه. انتهى بي الأمر إلى إلغاء تثبيت أدوات النظام الأساسي ، ثم إعادة التثبيت. ثم كل شيء آخر اعترف به.

0
dunno

وجدت من موقع مختلف

الخطوات لحل هذه المشكلة:

  1. افتح مدير SDK
  2. انتقل إلى أدوات -> خيارات
  3. ضمن "بيان ذاكرة التخزين المؤقت" ، انقر فوق "مسح ذاكرة التخزين المؤقت"
  4. ثم انتقل إلى "الحزم" وانقر على "تحديث"
0
user2762024

مسح ذاكرة التخزين المؤقت حل مشكلة بالنسبة لي. (أدوات> الخيار)

0
user3393662

أنا على MAC ، واجهت نفس السؤال. لم أتمكن من العثور على SDK Platform في API 18. الحل لحلها على mac هو تثبيت أدوات SDK أولاً ، ثم أعد تشغيل مدير sdk ومن ثم وجدت SDK Platform في API 18.

0
Jason Huang

حلا لنظامي مفقود SDK Android ، API 26 (يجب أن يعمل لـ API 18 أيضًا)

  1. تحديث أدوات SDK
  2. أعد تشغيل SDK Manager و Eclipse
  3. قم بتثبيت SDK Platform API 26 ، والذي أصبح مرئيًا الآن
  4. قم بتثبيت حزم API 26 الأخرى
0
David Trujillo

كنت أواجه نفس المشكلة ، ولكن مع API19 . قمت بتثبيت ما يلي بشكل فردي ، وأغلق Android SDK Manager بعد كل تثبيت (شكرًا cdoner):

  • أدوات SDK Android 22.3
  • مستودع دعم أندرويد 3

ثم تمكنت من تثبيت API19 لأنه لم يعد يرمي الخطأ. ( "تعتمد هذه الحزمة على" مفقود SDK Platform Android ، API19 ")

قررت العودة إلى الترميز بعد أكثر من 15 عامًا ، وأنا جديد تمامًا على Java و Android بعد قراءة الكتاب فقط ، Head Start Java . شكرًا لك على اتباع الخطوات السهلة ، خاصة بالنسبة لشخص جديد.

0
JenDav

واجهت هذه المشكلة على أجهزة تطوير Mac و Windows. الحل الوحيد هو إعادة تثبيت أحدث إصدار من Android SDK. جوجل حقا أسقط الكرة على هذا.

0
CpnCrunch

واجهت هذه المشكلة مع API 19. المفتاح بالنسبة لي لاستخدام Android SDK Manager الذي يبدأ في Eclipse. بعد ذلك ، عملت النصيحة أعلاه لإصلاح المشكلة.

الخلفية: نظرًا لوجود أشياء أخرى في سطر الأوامر كنت أفعلها ، بدأت تشغيل إدارة SDK بكتابة "Android" في الموجه. - وهذا هو الخطأ الذي كنت أقوم به.

0
pdschuller